using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([а-яё])""(?=[а-яё])";
string substitution = @"$1'";
string input = @"Эту ""задачу"" ""ну""ж""н""о сделать"" регулярным""и выраже""ниями";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}