re = /([а-яё])"(?=[а-яё])/i
str = 'Эту "задачу" "ну"ж"н"о сделать" регулярным"и выраже"ниями'
subst = '$1\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result