use strict;
my $str = 'Эту "задачу" "ну"ж"н"о сделать" регулярным"и выраже"ниями';
my $regex = qr/([а-яё])"(?=[а-яё])/ip;
my $subst = '$1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";