import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(user|email))(?=.*\\d)(?=.*[! @#$%^&*=+?.-])(?=.*[a-z]).{8,15}$";
final String string = "1234123a41234-\n"
+ "usernme1-\n"
+ "uer1-123sf\n"
+ "emaiz-a12d\n"
+ "aemail1a2!\n\n\n"
+ " At least Min Characters 8 and Maximum Characters 15\n"
+ " At least One Number and 1 special characters from (! @#$%^&*-=+?.);\n"
+ " At least One lower case letter\n"
+ " Password shouldn't be sub strings of username and email (min length 3 and max length 15).\n"
+ " Password should be case sensitive.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}