import re
regex = re.compile(r"^(?!.*(user|email))(?=.*\d)(?=.*[! @#$%^&*=+?.-])(?=.*[a-z]).{8,15}$", flags=re.MULTILINE)
test_str = ("1234123a41234-\n"
"usernme1-\n"
"uer1-123sf\n"
"emaiz-a12d\n"
"aemail1a2!\n\n\n"
" At least Min Characters 8 and Maximum Characters 15\n"
" At least One Number and 1 special characters from (! @#$%^&*-=+?.);\n"
" At least One lower case letter\n"
" Password shouldn't be sub strings of username and email (min length 3 and max length 15).\n"
" Password should be case sensitive.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")