use strict;
my $str = '1234123a41234-
usernme1-
uer1-123sf
emaiz-a12d
aemail1a2!
At least Min Characters 8 and Maximum Characters 15
At least One Number and 1 special characters from (! @#$%^&*-=+?.);
At least One lower case letter
Password shouldn\'t be sub strings of username and email (min length 3 and max length 15).
Password should be case sensitive.
';
my $regex = qr/^(?!.*(user|email))(?=.*\d)(?=.*[! @#$%^&*=+?.-])(?=.*[a-z]).{8,15}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}