using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"username=(?P<username>[^\s&]+)";
string input = @"username=test%40bmcm%2ecom&version=5%2e4%2e0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}