package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`username=(?P<username>[^\s&]+)`)
var str = `username=test%40bmcm%2ecom&version=5%2e4%2e0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}