$re = '/username=(?P<username>[^\s&]+)/';
$str = 'username=test%40bmcm%2ecom&version=5%2e4%2e0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);