using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:.*(?=\s)";
string substitution = @"";
string input = @"añsdlfslajdk http://api.ning.com/files/*tHd*uipNJAW29nIL5jzWbrYON5NhTKYVXmzollyMEHasDDvnq1454BrFkXFfmzj1gH7Ye3xw03C9ulNTICYAdueKg6vaIeu/PauloSkaf.png asdfljañsdlfjasfdsa";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}