re = /https?:.*(?=\s)/
str = 'añsdlfslajdk http://api.ning.com/files/*tHd*uipNJAW29nIL5jzWbrYON5NhTKYVXmzollyMEHasDDvnq1454BrFkXFfmzj1gH7Ye3xw03C9ulNTICYAdueKg6vaIeu/PauloSkaf.png asdfljañsdlfjasfdsa'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result