import re
regex = re.compile(r"https?:.*(?=\s)")
test_str = "añsdlfslajdk http://api.ning.com/files/*tHd*uipNJAW29nIL5jzWbrYON5NhTKYVXmzollyMEHasDDvnq1454BrFkXFfmzj1gH7Ye3xw03C9ulNTICYAdueKg6vaIeu/PauloSkaf.png asdfljañsdlfjasfdsa"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)