package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\]]+[[^\]])+(.*)`)
var str = `look[+3],panel button layout[+3],feature[+2]it 's very sleek looking with a very good front panel button layout , and it has a great feature set . "`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}