$re = '/([^\]]+[[^\]])+(.*)/';
$str = 'look[+3],panel button layout[+3],feature[+2]it \'s very sleek looking with a very good front panel button layout , and it has a great feature set . "';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);