re = /([^\]]+[[^\]])+(.*)/
str = 'look[+3],panel button layout[+3],feature[+2]it \'s very sleek looking with a very good front panel button layout , and it has a great feature set . "'
# Print the match result
str.match(re) do |match|
puts match.to_s
end