$re = '/^(?:[a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)(?:[.][a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)+$/m';
$str = 'www.google.com
google.com
goo gle.com
google.com
google.com
-www.google.com
www-.google.com
w-1.google.com
www.goo-gle.com
goo-gle.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);