using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)<p[^>]*>.*</p>\R?";
string substitution = @"$1";
string input = @"<p align=""justify"">First paragraph</p>
<p>Second paragraph</p>
<p>Third paragraph</p>
<div class=""item"">
<p>Some paragraph here</p>
<p><strong><u>Specs</u>:</strong><br /><br /><strong>Weight:</strong> 10kg<br /><br /><strong>LxWxH:</strong> 5mx1mx40cm</p
<p align=""justify"">second last para</p>
<p align=""justify"">This is the paragraph I am trying to remove with regex.</p>
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}