// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(.*)<p[^>]*>.*</p>\R?").unwrap();
let string = "<p align=\"justify\">First paragraph</p>
<p>Second paragraph</p>
<p>Third paragraph</p>
<div class=\"item\">
<p>Some paragraph here</p>
<p><strong><u>Specs</u>:</strong><br /><br /><strong>Weight:</strong> 10kg<br /><br /><strong>LxWxH:</strong> 5mx1mx40cm</p
<p align=\"justify\">second last para</p>
<p align=\"justify\">This is the paragraph I am trying to remove with regex.</p>
</div>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}