# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+?-)?hello(-.+)?$//gm;t' <<< "hi1-hello-hi2
hello
hello-hi1
hi1-hihello-hi2
hihello
hellohi
hellohi-hi2"