re = /^(.+?-)?hello(-.+)?$/m
str = 'hi1-hello-hi2
hello
hello-hi1
hi1-hihello-hi2
hihello
hellohi
hellohi-hi2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result