$re = '/^(.+?-)?hello(-.+)?$/m';
$str = 'hi1-hello-hi2
hello
hello-hi1
hi1-hihello-hi2
hihello
hellohi
hellohi-hi2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;