#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\RSLX-"
Local $sString = "SLX-9397._TC038IV_L_FLD0214.Read1.fq.gz" & @CRLF & _
"Sequences: 1406295" & @CRLF & _
"With index: 1300537" & @CRLF & _
"Sufficient length: 1300501" & @CRLF & _
"Min index: 0" & @CRLF & _
"Max index: 115" & @CRLF & _
"0 1299240" & @CRLF & _
"1 71" & @CRLF & _
"2 1" & @CRLF & _
"4 1" & @CRLF & _
"Unique: 86490" & @CRLF & _
"# reads processed: 86490" & @CRLF & _
"# reads with at least one reported alignment: 27433 (31.72%)" & @CRLF & _
"# reads that failed to align: 58544 (67.69%)" & @CRLF & _
"# reads with alignments suppressed due to -m: 513 (0.59%)" & @CRLF & _
"Reported 27433 alignments to 1 output stream(s)" & @CRLF & _
"SLX-9397._TC044II_D_FLD0197.Read1.fq.gz" & @CRLF & _
"Sequences: 308905" & @CRLF & _
"With index: 284599" & @CRLF & _
"Sufficient length: 284589" & @CRLF & _
"Min index: 0" & @CRLF & _
"Max index: 114" & @CRLF & _
"0 284290" & @CRLF & _
"1 16" & @CRLF & _
"Unique: 32715" & @CRLF & _
"# reads processed: 32715" & @CRLF & _
"# reads with at least one reported alignment: 13114 (40.09%)" & @CRLF & _
"# reads that failed to align: 19327 (59.08%)" & @CRLF & _
"# reads with alignments suppressed due to -m: 274 (0.84%)" & @CRLF & _
"Reported 13114 alignments to 1 output stream(s)" & @CRLF & _
"SLX-9397._TC047II_D_FLD0220.Read1.fq.gz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")