import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\RSLX-";
final String string = "SLX-9397._TC038IV_L_FLD0214.Read1.fq.gz\n"
+ "Sequences: 1406295\n"
+ "With index: 1300537\n"
+ "Sufficient length: 1300501\n"
+ "Min index: 0\n"
+ "Max index: 115\n"
+ "0 1299240\n"
+ "1 71\n"
+ "2 1\n"
+ "4 1\n"
+ "Unique: 86490\n"
+ "# reads processed: 86490\n"
+ "# reads with at least one reported alignment: 27433 (31.72%)\n"
+ "# reads that failed to align: 58544 (67.69%)\n"
+ "# reads with alignments suppressed due to -m: 513 (0.59%)\n"
+ "Reported 27433 alignments to 1 output stream(s)\n"
+ "SLX-9397._TC044II_D_FLD0197.Read1.fq.gz\n"
+ "Sequences: 308905\n"
+ "With index: 284599\n"
+ "Sufficient length: 284589\n"
+ "Min index: 0\n"
+ "Max index: 114\n"
+ "0 284290\n"
+ "1 16\n"
+ "Unique: 32715\n"
+ "# reads processed: 32715\n"
+ "# reads with at least one reported alignment: 13114 (40.09%)\n"
+ "# reads that failed to align: 19327 (59.08%)\n"
+ "# reads with alignments suppressed due to -m: 274 (0.84%)\n"
+ "Reported 13114 alignments to 1 output stream(s)\n"
+ "SLX-9397._TC047II_D_FLD0220.Read1.fq.gz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}