# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\RSLX-"
test_str = ("SLX-9397._TC038IV_L_FLD0214.Read1.fq.gz\n"
"Sequences: 1406295\n"
"With index: 1300537\n"
"Sufficient length: 1300501\n"
"Min index: 0\n"
"Max index: 115\n"
"0 1299240\n"
"1 71\n"
"2 1\n"
"4 1\n"
"Unique: 86490\n"
"# reads processed: 86490\n"
"# reads with at least one reported alignment: 27433 (31.72%)\n"
"# reads that failed to align: 58544 (67.69%)\n"
"# reads with alignments suppressed due to -m: 513 (0.59%)\n"
"Reported 27433 alignments to 1 output stream(s)\n"
"SLX-9397._TC044II_D_FLD0197.Read1.fq.gz\n"
"Sequences: 308905\n"
"With index: 284599\n"
"Sufficient length: 284589\n"
"Min index: 0\n"
"Max index: 114\n"
"0 284290\n"
"1 16\n"
"Unique: 32715\n"
"# reads processed: 32715\n"
"# reads with at least one reported alignment: 13114 (40.09%)\n"
"# reads that failed to align: 19327 (59.08%)\n"
"# reads with alignments suppressed due to -m: 274 (0.84%)\n"
"Reported 13114 alignments to 1 output stream(s)\n"
"SLX-9397._TC047II_D_FLD0220.Read1.fq.gz")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.