$re = '/(\d{2}.\d{2}.\d{4}).*?(\d{2}:\d{2}:\d{2}).\d{0,3}.*?\*(ERROR)\*.*?(\[.*?\]).(.*?\..*?)\s+?(.+)\n/s';
$str = '30.08.2016 08:00:00.004 *ERROR* [pool-7-thread-5] com.day.cq.reporting.impl.snapshots.SnapshotServiceImpl Error accessing repository during creation of report snapshot data
javax.jcr.LoginException: Cannot derive user name for bundle com.day.cq.cq-reporting [313] and sub service null
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);