re = /(\d{2}.\d{2}.\d{4}).*?(\d{2}:\d{2}:\d{2}).\d{0,3}.*?\*(ERROR)\*.*?(\[.*?\]).(.*?\..*?)\s+?(.+)\n/
str = '30.08.2016 08:00:00.004 *ERROR* [pool-7-thread-5] com.day.cq.reporting.impl.snapshots.SnapshotServiceImpl Error accessing repository during creation of report snapshot data
javax.jcr.LoginException: Cannot derive user name for bundle com.day.cq.cq-reporting [313] and sub service null
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end