package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)id="(.*)"`)
var str = ` <property id="leftLogoURL" labelText="Override Left Logo URL" dataType="string" defaultValue=""></property>
<property id="rightLogoURL" labelText="Override Right Logo URL" dataType="string" defaultValue=""></property>
<property id="title" labelText="Override Group Title" dataType="string" defaultValue=""></property>
<property id="description" labelText="Override Group Description" dataType="string" rows="2" defaultValue=""></property>
<property id="underDescription" labelText="HTML Under Description" dataType="html" rows="5" defaultValue=""></property>
<property id="button1state" labelText="Button 1 Display Mode" dataType="string" defaultValue="Standard">
<propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button1label,button1url" propertiesToShow="" />
<propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button1label,button1url" />
<propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button1label,button1url" propertiesToShow="" />
</property>
<property id="button1label" labelText="Button 1 Label" dataType="string" defaultValue=""></property>
<property id="button1url" labelText="Button 1 URL" dataType="string" defaultValue=""></property>
<property id="button2state" labelText="Button 2 Display Mode" dataType="string" defaultValue="Standard">
<propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button2label,button2url" propertiesToShow="" />
<propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button2label,button2url" />
<propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button2label,button2url" propertiesToShow="" />
</property>
<property id="button2label" labelText="Button 2 Label" dataType="string" defaultValue=""></property>
<property id="button2url" labelText="Button 2 URL" dataType="string" defaultValue=""></property>
<property id="button3state" labelText="Button 3 Display Mode" dataType="string" defaultValue="Standard">
<propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button3label,button3url" propertiesToShow="" />
<propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button3label,button3url" />
<propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button3label,button3url" propertiesToShow="" />
</property>
<property id="button3label" labelText="Button 3 Label" dataType="string" defaultValue=""></property>
<property id="button3url" labelText="Button 3 URL" dataType="string" defaultValue=""></property>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}