import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "id=\"(.*)\"";
final String string = " <property id=\"leftLogoURL\" labelText=\"Override Left Logo URL\" dataType=\"string\" defaultValue=\"\"></property>\n"
+ " <property id=\"rightLogoURL\" labelText=\"Override Right Logo URL\" dataType=\"string\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"title\" labelText=\"Override Group Title\" dataType=\"string\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"description\" labelText=\"Override Group Description\" dataType=\"string\" rows=\"2\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"underDescription\" labelText=\"HTML Under Description\" dataType=\"html\" rows=\"5\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"button1state\" labelText=\"Button 1 Display Mode\" dataType=\"string\" defaultValue=\"Standard\">\n"
+ " <propertyValue value=\"Automatic\" labelText=\"Automatic\" propertiesToHide=\"button1label,button1url\" propertiesToShow=\"\" />\n"
+ " <propertyValue value=\"Overriden\" labelText=\"Overriden\" propertiesToHide=\"\" propertiesToShow=\"button1label,button1url\" />\n"
+ " <propertyValue value=\"Disabled\" labelText=\"Disabled\" propertiesToHide=\"button1label,button1url\" propertiesToShow=\"\" />\n"
+ " </property>\n"
+ " <property id=\"button1label\" labelText=\"Button 1 Label\" dataType=\"string\" defaultValue=\"\"></property>\n"
+ " <property id=\"button1url\" labelText=\"Button 1 URL\" dataType=\"string\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"button2state\" labelText=\"Button 2 Display Mode\" dataType=\"string\" defaultValue=\"Standard\">\n"
+ " <propertyValue value=\"Automatic\" labelText=\"Automatic\" propertiesToHide=\"button2label,button2url\" propertiesToShow=\"\" />\n"
+ " <propertyValue value=\"Overriden\" labelText=\"Overriden\" propertiesToHide=\"\" propertiesToShow=\"button2label,button2url\" />\n"
+ " <propertyValue value=\"Disabled\" labelText=\"Disabled\" propertiesToHide=\"button2label,button2url\" propertiesToShow=\"\" />\n"
+ " </property>\n"
+ " <property id=\"button2label\" labelText=\"Button 2 Label\" dataType=\"string\" defaultValue=\"\"></property>\n"
+ " <property id=\"button2url\" labelText=\"Button 2 URL\" dataType=\"string\" defaultValue=\"\"></property>\n\n"
+ " <property id=\"button3state\" labelText=\"Button 3 Display Mode\" dataType=\"string\" defaultValue=\"Standard\">\n"
+ " <propertyValue value=\"Automatic\" labelText=\"Automatic\" propertiesToHide=\"button3label,button3url\" propertiesToShow=\"\" />\n"
+ " <propertyValue value=\"Overriden\" labelText=\"Overriden\" propertiesToHide=\"\" propertiesToShow=\"button3label,button3url\" />\n"
+ " <propertyValue value=\"Disabled\" labelText=\"Disabled\" propertiesToHide=\"button3label,button3url\" propertiesToShow=\"\" />\n"
+ " </property>\n"
+ " <property id=\"button3label\" labelText=\"Button 3 Label\" dataType=\"string\" defaultValue=\"\"></property>\n"
+ " <property id=\"button3url\" labelText=\"Button 3 URL\" dataType=\"string\" defaultValue=\"\"></property>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}