using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"final states\s*=\s*{([^}]*)}";
string input = @"final states = {q2}
final states = {q2, q3,q4}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}