re = /final states\s*=\s*{([^}]*)}/m
str = 'final states = {q2}
final states = {q2, q3,q4}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end