const regex = /final states\s*=\s*{([^}]*)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('final states\\s*=\\s*{([^}]*)}', 'gm')
const str = `final states = {q2}
final states = {q2, q3,q4}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}