import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(watch\\?v=|embed\\/)([\\d\\w-_]+)";
final String string = "aaa@adasd.com\n"
+ "adas@asdas.com.br\n"
+ "https://www.youtube.com/watch?v=C8UMTmUbxTI\n"
+ "http://www.youtube.com/watch?v=C8UMTmUbxTI\n"
+ "www.youtube.com/embed/C8UMTmUbxTI\n"
+ "www.youtube.com.br/embed/C8UMTmUbxTI?rel=0\n"
+ "m.youtube.com/watch?v=C8UMTmUbxTI";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}