import re
regex = re.compile(r"\/(watch\?v=|embed\/)([\d\w-_]+)", flags=re.MULTILINE)
test_str = ("aaa@adasd.com\n"
"adas@asdas.com.br\n"
"https://www.youtube.com/watch?v=C8UMTmUbxTI\n"
"http://www.youtube.com/watch?v=C8UMTmUbxTI\n"
"www.youtube.com/embed/C8UMTmUbxTI\n"
"www.youtube.com.br/embed/C8UMTmUbxTI?rel=0\n"
"m.youtube.com/watch?v=C8UMTmUbxTI")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")