#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)[\w-]+\.jpg"
Local $sString = "101018-202x300.jpg" & @CRLF & _
"100116-215x300.jpg" & @CRLF & _
"1000748-300x157.jpg" & @CRLF & _
"100138-196x300.jpg" & @CRLF & _
"100308-companion-in-surgical-studies-208x300.jpg" & @CRLF & _
"100463-Ambroise-Pare-300x216.jpg" & @CRLF & _
"100523-Grulee-collection-pediatrics-194x300.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")