# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)[\w-]+\.jpg"
test_str = ("101018-202x300.jpg\n"
"100116-215x300.jpg\n"
"1000748-300x157.jpg\n"
"100138-196x300.jpg\n"
"100308-companion-in-surgical-studies-208x300.jpg\n"
"100463-Ambroise-Pare-300x216.jpg\n"
"100523-Grulee-collection-pediatrics-194x300.jpg")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.