import re
regex = re.compile(r"^\p{Lu}", flags=re.MULTILINE | re.UNICODE)
test_str = ("This is string\n"
"this is string\n"
"5 not goodD\n"
"Увеличи starts capital\n"
"мащабиране no capital")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")