re = /^\p{Lu}/m
str = 'This is string
this is string
5 not goodD
Увеличи starts capital
мащабиране no capital'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end