package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\.\d+\.\d+\.\d+`)
var str = `<div>Please send such and such files to IP 161.134.220.122 Thanks in advance.</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}