re = /\d+\.\d+\.\d+\.\d+/m
str = '<div>Please send such and such files to IP 161.134.220.122 Thanks in advance.</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end