#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\"[^\"]+\"|[^\|\>\<\:\s\"]+)([^\|\<\>\n\r]*)(\||\>.*)?"
Local $sString = "Illeszkedjen:" & @CRLF & _
" Alapesetek:" & @CRLF & _
"cat ezmeg.az | grep "azta" | sort -n > ez.txt" & @CRLF & _
"cat ezmeg.az | grep "az ta" | sort -n > ez.txt" & @CRLF & _
"head -n 1 -r text.txt > head.txt" & @CRLF & _
"head -n 1 text.txt" & @CRLF & _
"head text.txt | tail" & @CRLF & _
"ls" & @CRLF & _
"" & @CRLF & _
" Extrém esetek:" & @CRLF & _
"cat ezmeg.az |sort -n > ez.txt" & @CRLF & _
"cat ezmeg.az |sort -n | sort -n | sort -n> ez.txt" & @CRLF & _
"cat ezmeg.az |grep "azta" | sort -n > ez.txt" & @CRLF & _
"cat ezmeg.az -n --help | grep "azta" | sort -n -h > ez.txt" & @CRLF & _
"cat ezmeg.az | azta.exe | sort -n > ez.txt" & @CRLF & _
"cat ezmeg.az | grep "azta" | sort -n" & @CRLF & _
"cat ezmeg.az | grep "azta" | sort -n > ez.txt" & @CRLF & _
"cat ezmeg.az | grep "azta" | sort -n>ez.txt" & @CRLF & _
""my program.exe" --help > help.txt" & @CRLF & _
"head -n 1 text.txt > "head file.txt"" & @CRLF & _
"" & @CRLF & _
"Ne illeszkedjen:" & @CRLF & _
"head -n 1 text.txt > head.txt -x" & @CRLF & _
"head -n 1 text.txt > head.txt | tail" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)