# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"[^\"]+\"|[^\|\>\<\:\s\"]+)([^\|\<\>\n\r]*)(\||\>.*)?"
test_str = ("Illeszkedjen:\n"
" Alapesetek:\n"
"cat ezmeg.az | grep \"azta\" | sort -n > ez.txt\n"
"cat ezmeg.az | grep \"az ta\" | sort -n > ez.txt\n"
"head -n 1 -r text.txt > head.txt\n"
"head -n 1 text.txt\n"
"head text.txt | tail\n"
"ls\n\n"
" Extrém esetek:\n"
"cat ezmeg.az |sort -n > ez.txt\n"
"cat ezmeg.az |sort -n | sort -n | sort -n> ez.txt\n"
"cat ezmeg.az |grep \"azta\" | sort -n > ez.txt\n"
"cat ezmeg.az -n --help | grep \"azta\" | sort -n -h > ez.txt\n"
"cat ezmeg.az | azta.exe | sort -n > ez.txt\n"
"cat ezmeg.az | grep \"azta\" | sort -n\n"
"cat ezmeg.az | grep \"azta\" | sort -n > ez.txt\n"
"cat ezmeg.az | grep \"azta\" | sort -n>ez.txt\n"
"\"my program.exe\" --help > help.txt\n"
"head -n 1 text.txt > \"head file.txt\"\n\n"
"Ne illeszkedjen:\n"
"head -n 1 text.txt > head.txt -x\n"
"head -n 1 text.txt > head.txt | tail\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.