re = /(\"[^\"]+\"|[^\|\>\<\:\s\"]+)([^\|\<\>\n\r]*)(\||\>.*)?/
str = 'Illeszkedjen:
Alapesetek:
cat ezmeg.az | grep "azta" | sort -n > ez.txt
cat ezmeg.az | grep "az ta" | sort -n > ez.txt
head -n 1 -r text.txt > head.txt
head -n 1 text.txt
head text.txt | tail
ls
Extrém esetek:
cat ezmeg.az |sort -n > ez.txt
cat ezmeg.az |sort -n | sort -n | sort -n> ez.txt
cat ezmeg.az |grep "azta" | sort -n > ez.txt
cat ezmeg.az -n --help | grep "azta" | sort -n -h > ez.txt
cat ezmeg.az | azta.exe | sort -n > ez.txt
cat ezmeg.az | grep "azta" | sort -n
cat ezmeg.az | grep "azta" | sort -n > ez.txt
cat ezmeg.az | grep "azta" | sort -n>ez.txt
"my program.exe" --help > help.txt
head -n 1 text.txt > "head file.txt"
Ne illeszkedjen:
head -n 1 text.txt > head.txt -x
head -n 1 text.txt > head.txt | tail
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result