#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=search=)[^+]*?(?=&|$)"
Local $sString = "jobs?search=term1&location=&distance=10+page=2" & @CRLF & _
"jobs?search=term1+term2&location=ca&distance=30" & @CRLF & _
"jobs?search=term1+term2+term3&location=nyc&distance=25"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")