import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=search=)[^+]*?(?=&|$)";
final String string = "jobs?search=term1&location=&distance=10+page=2\n"
+ "jobs?search=term1+term2&location=ca&distance=30\n"
+ "jobs?search=term1+term2+term3&location=nyc&distance=25";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}