re = /(?<=search=)[^+]*?(?=&|$)/
str = 'jobs?search=term1&location=&distance=10+page=2
jobs?search=term1+term2&location=ca&distance=30
jobs?search=term1+term2+term3&location=nyc&distance=25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end