package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<requestedURI>\/api[^?]+)\?.* (?<requestProcessedTime>\d+)\s*$`)
var str = `12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}