import re
regex = re.compile(r"(?<requestedURI>\/api[^?]+)\?.* (?<requestProcessedTime>\d+)\s*$", flags=re.MULTILINE)
test_str = "12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")