const regex = /(?<requestedURI>\/api[^?]+)\?.* (?<requestProcessedTime>\d+)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<requestedURI>\\\/api[^?]+)\\?.* (?<requestProcessedTime>\\d+)\\s*$', 'gm')
const str = `12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}