$re = '/^(class[^\S\n].*)((?:\n(?!class ).*)+)/m';
$str = 'class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y
class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y
class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);