re = /^(class[^\S\n].*)((?:\n(?!class ).*)+)/m
str = 'class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y
class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y
class friendly():
def __init__(x, y, z):
self.x = x
self.y = y
self.z = z
def printme():
print(self.x)
class unfriendly():
def friendme():
assert self.x == self.y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end